[closed] Help with CGminer and/or Reaper for mining LTC

I have been trying to GPU mine litecoins, but I am running into several different problems. I have a Radeon 5770 on WinXP32, 13.1 Catalyst drivers, the 2.6 sdk.

Reaper runs, but does not detect anything other than my CPU, which it quickly overheats past 75c

CGminer's precompiled version runs into this:

----------------------------------
Started cgminer 2.10.5
Error -1: Getting Device IDs (num)
clDevicesNum returned error, no GPUs usable
All devices disabled, cannot mine!
----------------------------------

I tried following the build instructions myself, but when I got to compiling it I get this:

----------------------------------
configure:2746: checking build system type
configure:2760: result: i686-pc-mingw32
configure:2780: checking host system type
configure:2793: result: i686-pc-mingw32
configure:2813: checking target system type
configure:2826: result: i686-pc-mingw32
configure:2874: checking for a BSD-compatible install
configure:2942: result: /bin/install -c
configure:2953: checking whether build environment is sane
configure:3003: result: yes
configure:3144: checking for a thread-safe mkdir -p
configure:3183: result: /bin/mkdir -p
configure:3197: checking for gawk
configure:3213: found /bin/gawk
configure:3224: result: gawk
configure:3235: checking whether make sets $(MAKE)
configure:3257: result: yes
configure:3361: checking for style of include used by make
configure:3389: result: GNU
configure:3459: checking for gcc
configure:3475: found /mingw/bin/gcc
configure:3486: result: gcc
configure:3715: checking for C compiler version
configure:3724: gcc --version >&5
gcc.exe (GCC) 4.7.2
Copyright (C) 2012 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3735: $? = 0
configure:3724: gcc -v >&5
Using built-in specs.
COLLECT_GCC=C:\MinGW\bin\gcc.exe
COLLECT_LTO_WRAPPER=c:/mingw/bin/../libexec/gcc/mingw32/4.7.2/lto-wrapper.exe
Target: mingw32
Configured with: ../gcc-4.7.2/configure --enable-languages=c,c++,ada,fortran,objc,obj-c++ --disable-sjlj-exceptions --with-dwarf2 --enable-shared --enable-libgomp --disable-win32-registry --enable-libstdcxx-debug --disable-build-poststage1-with-cxx --enable-version-specific-runtime-libs --build=mingw32 --prefix=/mingw
Thread model: win32
gcc version 4.7.2 (GCC)
configure:3735: $? = 0
configure:3724: gcc -V >&5
gcc.exe: error: unrecognized command line option '-V'
gcc.exe: fatal error: no input files
compilation terminated.
configure:3735: $? = 1
configure:3724: gcc -qversion >&5
gcc.exe: error: unrecognized command line option '-qversion'
gcc.exe: fatal error: no input files
compilation terminated.
configure:3735: $? = 1
configure:3755: checking whether the C compiler works
configure:3777: gcc -02 -msse2   conftest.c  >&5
gcc.exe: error: unrecognized command line option '-02'
configure:3781: $? = 1
configure:3819: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "cgminer"
| #define PACKAGE_TARNAME "cgminer"
| #define PACKAGE_VERSION "2.10.5"
| #define PACKAGE_STRING "cgminer 2.10.5"
| #define PACKAGE_BUGREPORT "[email protected]"
| #define PACKAGE_URL ""
| #define PACKAGE "cgminer"
| #define VERSION "2.10.5"
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:3824: error: in `/home/username/cgminer-master':
configure:3826: error: C compiler cannot create executables
See `config.log' for more details
----------------------------------

Any help with any of these problems would be greatly appreciated

asked 28 Feb '13, 23:26 Marvin Fla... 204126 Marvin%20Flarvin's gravatar image
closed 13 Mar '13, 19:20

hi @Marvin Flarvin, do you like some answer?

(08 Mar '13, 16:22) paraipan paraipan's gravatar image
(08 Mar '13, 19:32) splat44 splat44's gravatar image

The question has been closed for the following reason "tehmwak won 1.00 mBTC for the best answer." by Marvin Flarvin 13 Mar '13, 19:20


Try setting your litecoin.conf for reaper to

host notroll.in

port 6332

user cheeselover.5

pass 12345

protocol litecoin

worksize 256

aggression 10

threads_per_gpu 1

sharethreads 18

lookup_gap 2

gpu_thread_concurrency 6144


And your reaper.conf to

kernel reaper.cl

save_binaries yes

enable_graceful_shutdown no

long_polling yes

mine litecoin


Change your pool/user/pass to be whatever you want them to be. That Should work for you.

link
answered 02 Mar '13, 05:22 tehmwak 1188 tehmwak's gravatar image
edited 02 Mar '13, 05:24

Thanks, but other than the pool login credentials, I have everything set up like that already. I posted what the startup looks like in this thread: http://www.rugatu.com/questions/8881/reaper-not-seeing-5770-only-i3-integrated-graphics

The problem seems to be that my 5770 isn't even being recognized as a device in Reaper. Not sure what's wrong with cgminer and bfgminer, except that they don't detect my real gpu either

(02 Mar '13, 05:26) Marvin Fla... Marvin%20Flarvin's gravatar image

configure:3724: gcc -V >&5 gcc.exe: error: unrecognized command line option '-V'

gcc.exe: error: unrecognized command line option '-02'

What's option -V and -02 supposed to be? And can you attach the log of why the compile failed?

Also; On a side note, I've had a few issues with running miners on winXP. And my laptop's 4650 isn't being recognized as a gpu but it still works. (I don't question it, I just pretend I didn't notice the message...)

(02 Mar '13, 06:54) tehmwak tehmwak's gravatar image

-02 was something it said to add in the windows-build.txt file in the cgminer directory which I tried to follow exactly line by line. Here is the full config.log of the fail:

http://pastebin.com/C545Nfzw

(02 Mar '13, 07:05) Marvin Fla... Marvin%20Flarvin's gravatar image

http://ck.kolivas.org/apps/cgminer/ <-- You can find all the compiled versions there, when splat44 says that 2.4.2 is the latest version... I think he is ill-informed. But the direct link for that is ck.kolivas.org/apps/cgminer/2.4/cgminer-2.4.4-win32.zip

The only things I can suggest are trying 12.8 drivers or trying a newer OS.

I'm sorry. Bad new's I know.

(02 Mar '13, 07:26) tehmwak tehmwak's gravatar image

Ok, my mistake but don't treat me as some kind of a fool! Restrain yourself!

(02 Mar '13, 07:48) splat44 splat44's gravatar image

I could be much meaner. That was the most tactful way of saying it I could think of.

No offense intended. Just trying to get the information across to someone who needs it.

(02 Mar '13, 08:14) tehmwak tehmwak's gravatar image
showing 5 of 6 show all

I recall receiving that kind of error while trying mining for BTC.

I suggest trying the most recent version of cgminer. I know the recent version is: cgminer-2.4.2

Additionally refer to following for setting of cgminer:

https://github.com/ckolivas/cgminer/blob/master/README

Not sure if the above applies to recent version but you might need doing further reasearch.

Warning

LTC is best designed to mine on CPU than GPU refer to below closed discussion

http://www.rugatu.com/questions/4972/litecoins-bitcoins

If you really must user reaper for ltc mining on GPU the following link provide solution toward configuration files including compiling!

https://bitcointalk.org/index.php?topic=91979.0;all

link
answered 02 Mar '13, 06:11 splat44 4.5k17 splat44's gravatar image
edited 02 Mar '13, 10:55

Appreciate it, though that is the version I am using. I understand too the differences between the coins, but I'd rather try to mine litecoins at the moment. In any case, I imagine I'd have the same problem with these miners regardless of protocol.

(02 Mar '13, 06:51) Marvin Fla... Marvin%20Flarvin's gravatar image

Nix that, I mean the compiled version I have is 2.10.5. Will see if I can find the version you're talking about

(02 Mar '13, 06:53) Marvin Fla... Marvin%20Flarvin's gravatar image

I just update my anwser, look at the last link!

(02 Mar '13, 10:55) splat44 splat44's gravatar image

Here is an example, my cgminer startup bat file for windows. Radeon 7970 solo mining Solo mining guide.

 cgminer.exe --scrypt -I 13 -g 4 -o 127.0.0.1:9332 -u one -p one

To use this with a pool just change the 127.0.0.1 to your pool address:port change to your username and password.

-I is the intensity start it lower and then increase until it crashes and then lower until stable.

-g is the number of threads check the statistics and see what gives you higher khashes. normal is 2 threads.

I'm not too sure about reaper but cgminer has worked great for me.

link
answered 01 Mar '13, 00:31 Unmotivate... 7055 UnmotivatedGenius's gravatar image

I appreciate your replies, but it doesn't really address the issue I'm having. For some reason, my video card is not showing as available to any of the GPU mining programs. I used to have Electric Sheep running, and killing that got Reaper to fail in a different way, at least.

(02 Mar '13, 05:08) Marvin Fla... Marvin%20Flarvin's gravatar image

as @unmotivatedgenius explained about cgminer working, it certain worked for me as well on my windows 7 laptop.

I used to have an ATI intergrate graphic and when trying using cgminer, it couldn't detect GPU until I install Catalyst!

You might try unsinstalling/reinstalling Catalyst and see!

Again, I am very reluctant in mining for LTC on GPU as already explained my answer!

(02 Mar '13, 09:42) splat44 splat44's gravatar image

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×12
×10
×3
×3

Asked: 28 Feb '13, 23:26

Seen: 10,956 times

Last updated: 13 Mar '13, 19:20



Bitcoin forums:
Bitcointalk.org
p2p Bitcoin forum
Bitcoinforum.com

Blogs and press:
elBitcoin.org (ES)
Que es bitcoin.info (ES)
bitcoinInformant.com
bitcoinmagazine.net

Partners:
Bitcoinerr.com
ogrr.com
The Unoff. Bitcoin Forum